Pump not helping

Specific talk about pumps: Questions, hints, recommendations, etc.

Moderator: Larry10625

ocitgo
Posts: 305
Joined: Wed Jan 01, 2014 8:48 pm
Contact:

Re: Pump not helping

Postby ocitgo » Fri Mar 24, 2017 8:05 am

This is great info. Read page 10 for how I load the pump.

http://www.vitalitymedical.com/pdf/osbo ... manual.pdf
ocitgo (Bob F), Bremerton, WA
Implanted 11/13/2017 AMS 700LGX 15 cm, 3 cm rear tip
Manas Jain, MD, Chi Franciscan, Harrison Medical Center Bremerton
BMT for Leukemia (9/9/1993) Fred Hutch, Seattle

User avatar
Bionic_by_AMS
Posts: 573
Joined: Wed Apr 04, 2012 2:59 pm
Location: NJ

Re: Pump not helping

Postby Bionic_by_AMS » Fri Mar 24, 2017 2:53 pm

jelquinginjury,
No I have not had any issues with VED and my Implant ... I have venous leak so it's hard to maintain the "swell" in the glans, so I use the VED and a ring and get great results.

There are several other guys here with Implants that use the VED ... [Example]
Member: Genome
http://www.franktalk.org/phpBB3/viewtopic.php?f=6&t=231&start=130
"So for the next 8 months i will use a VED pump to help me regain as much of my lost length as possible."

The ring that I use is from Amazon.com and costs $7 ... it also serves as a padded seal on a vacuum tube ...
https://www.amazon.com/California-Exotics-Kaplan-Erection-Enhancer/dp/B002JINW56/?th=1
ring.jpg
ring.jpg (8.46 KiB) Viewed 612 times


Luha71,
Bionic...Are you flacid when you put the pump on?

I usually pump my Implant to about 50% ... but it doesn't matter as I'm 5.5" flaccid, and as you can see in the above image I can hit the top of a 8" tube ...
Robotic Prostrate surgery - Dec. 2011 - AMS 700 LGX Implant - 21 cm/3 cm RTE - June 2012


Return to “Pumps”

Who is online

Users browsing this forum: No registered users and 2 guests