Sticky pump difficult to click valve to start pumping

The final frontier. Deciding when, if and how.
Kurt0726
Posts: 35
Joined: Sat Jun 29, 2019 7:48 am

Sticky pump difficult to click valve to start pumping

Postby Kurt0726 » Sat May 09, 2020 3:00 pm

Hello all. I was installed with a titan touch about 3 months ago during a revision surgery. I had genesis pump before.
I am having the hardest time getting this thing to work consistently. Half the time it works fine e with no problems. The other half of the time I cannot initiate the the first pump. In other words it doesn't "click" or pop to set it into inflate mode. I have started to give it one pump after I deflate just to prep it like the manual says. But still half the time it doesn't "click" over.. I have to hit the deflate valve a couple times and then pump and then it clicks over.
Is this just due to a new pump than needs "broken in" ? It certainly hasn't gotten better at all. Anyone else experiencing this? Wtf do I do about it cause its driving me nuts

Gordon
Posts: 148
Joined: Mon Dec 05, 2016 9:16 am
Location: Somewhere in Alabama

Re: Sticky pump difficult to click valve to start pumping

Postby Gordon » Sat May 09, 2020 3:37 pm

I have an AMS LGX 700. Mine does the same thing sometimes. I just push the release button and then it will reset.
Married 64
AMS LGX 700 2/15/2017

Kurt0726
Posts: 35
Joined: Sat Jun 29, 2019 7:48 am

Re: Sticky pump difficult to click valve to start pumping

Postby Kurt0726 » Sat May 09, 2020 8:27 pm

Yes pushing the release valve works on my titan as well. The problem I have to do it about half the time I try to use the pump. My concern is that I am putting unnecessary wear and tear on the pump. I'm also concerned the pump isn't working g the way it is supposed to/advertized.
25 years old. 20cm Coloplast Titan installed by Doctor Perito 6/19/2019. Pump failure/ revision with titan touch 2/28/20

Kurt0726
Posts: 35
Joined: Sat Jun 29, 2019 7:48 am

Re: Sticky pump difficult to click valve to start pumping

Postby Kurt0726 » Sat May 09, 2020 8:39 pm

Anyone else experiencing similar problems???
25 years old. 20cm Coloplast Titan installed by Doctor Perito 6/19/2019. Pump failure/ revision with titan touch 2/28/20

medhatg
Posts: 293
Joined: Thu Sep 14, 2017 10:34 pm

Re: Sticky pump difficult to click valve to start pumping

Postby medhatg » Sat Jun 06, 2020 3:10 pm

Kurt0726 wrote:Anyone else experiencing similar problems???

I've a new AMS pump and it is doing the same some times. It is scary as I just had a revision.
Try to sit in the bathtub in warm water and see if it helps.

Frederickdave
Posts: 38
Joined: Tue Oct 29, 2019 8:22 am

Re: Sticky pump difficult to click valve to start pumping

Postby Frederickdave » Sat Jun 06, 2020 10:47 pm

My AMS didnt work reliably till about month 5. Now when I want to use it, I hit the deflate button and squeeze all the saline out of the implant. The inflate valve "pops" first time, almost everytime if I follow that process. It just needs to be broken in.

vajim1
Posts: 265
Joined: Tue Jan 16, 2018 2:19 pm

Re: Sticky pump difficult to click valve to start pumping

Postby vajim1 » Sun Jun 07, 2020 7:55 am

Mine too, not all the time but sometime it takes two or three times to get it to release.
76 year old fart. Prostate removed Oct. 9, 2017,Psa 30 days after .15 next Psa .2. 37 Radiation treatments for recurrent cancer, 1 year out Psa .033 ZERO ERECTIONS, implanted Sept 5 2019 Dr. Lentz Duke Raleigh N.C. Titan 22cm.

medhatg
Posts: 293
Joined: Thu Sep 14, 2017 10:34 pm

Re: Sticky pump difficult to click valve to start pumping

Postby medhatg » Sun Jun 07, 2020 10:46 am

vajim1 wrote:Mine too, not all the time but sometime it takes two or three times to get it to release.


It is scary, and sometimes make me panic. I hope my AMS pump gets better.
Has anyone heard of MS Pump failures right off the bat?

Steve87
Posts: 62
Joined: Sat Feb 15, 2020 5:45 pm

Re: Sticky pump difficult to click valve to start pumping

Postby Steve87 » Thu Jun 18, 2020 2:36 pm

I have an ams Cx installed on January. Pump stopped working about 1 months ago. Issue started as deflation problem and now it stopped working at all. Tomorrow I'll have my revision surgery to replace the pump.
32 yo, VL from birth. Implanted with infrapubic approach on 1/20/20 with AMS CX 21+4 by Gabriele Antonini. Pump stopped working after three months,replaced on 06/19/20. New pump not working properly again. Replacement with Titan Touch 24+1 by Dr.Eid


Return to “Implants”

Who is online

Users browsing this forum: Jimjump and 23 guests