AMS 700 Malfunctioning?

The final frontier. Deciding when, if and how.

Moderator: DaveKell

Drake1
Posts: 15
Joined: Mon Jul 08, 2019 6:34 am

AMS 700 Malfunctioning?

Postby Drake1 » Tue Jul 09, 2019 9:52 am

I had my AMS 700 pump installed in 08/2011 and have never had issues until two days ago. I pumped one time and the ball would not re-fill. I then pressed the deflate button and the ball did re-fill. After attempting this same procedure several times this was the only action I could get out of my implant. Does any one in this group have any experience with the AMS 700 implant? Any information at all would be great!

RayChez
Posts: 182
Joined: Sat Mar 17, 2018 11:25 pm

Re: AMS 700 Malfunctioning?

Postby RayChez » Tue Jul 09, 2019 1:44 pm

I had problems after 10 months of my revision. But mine started acting up from the start. It seemed to me like the valve on the MS pump would get stuck, then it would make like a popping sound and it would work. Finally it completely stopped working. I had a partial revision in Feb 2019 and everything seems to be working perfect now. I went into surgery thinking they were only going to change the MS pump even though I could tell he did not like to just change the pump. He told me that AMS would not let them do that. So I called the representative for AMS and they said that they did not mind a partial as long as it was less then five years the last operation I had. So on the last surgery they did not replace the cylinders, he just pulled them more into the gland so the tips would be right around the center, but he told me they replaced the MS pump and they also installed a bigger reservoir. Replaced the rte's to the correct length. But the surgeon still would not admit that it was a bad MS pump. Even though I am a retired mechanical engineer and understand exactly how these things work. He said he still did not know what caused the failure. Maybe to protect AMS or maybe to protect the previous surgeon, but I never got a straight answer. He done a great job on this revision. I was all healed up within three weeks.
age: 75 First implant around 2001, 59 at the time. AMS 700 Ultrex
revision Dec 2016. 2ND implant 21CM, 1rte AMS 700 LGX MS pump

Lost Sheep
Posts: 2521
Joined: Mon Jul 04, 2016 11:16 pm

Re: AMS 700 Malfunctioning?

Postby Lost Sheep » Tue Jul 09, 2019 2:01 pm

So, you are not able to inflate the implant to a full (or even partial) erection?
Lost Sheep
Born 1948 AMS LGX 18+3 implant Nov 6, 2017 by Dr Tavis Shaw. Spent 14 months researching in effort to optimize outcome. After 30 yrs of progressive unrecognized ED I will do this RIGHT; no second chance with one's first.
Anchorage AK, USA

RayChez
Posts: 182
Joined: Sat Mar 17, 2018 11:25 pm

Re: AMS 700 Malfunctioning?

Postby RayChez » Wed Jul 10, 2019 1:36 pm

You need to get that MS pump replaced. Pretty sure that is the problem. Simple operation if they do just that, but sometimes these surgeon will do more.

But if the ball stays collapsed the valve is not resetting itself. It got stuck on the open position and will not hold the saline that is pushed into the cylinders. Pretty sure that is what happened with mine.
age: 75 First implant around 2001, 59 at the time. AMS 700 Ultrex
revision Dec 2016. 2ND implant 21CM, 1rte AMS 700 LGX MS pump

User avatar
Lunatech
Posts: 88
Joined: Wed Nov 28, 2018 2:07 pm
Location: Foothills of NC

Re: AMS 700 Malfunctioning?

Postby Lunatech » Wed Jul 10, 2019 8:53 pm

Contact Jamie. She's an AMS patient service specialist. If anyone can walk you through getting a pump to work again (unless it truly is broken) it's her. I've spoken with her before and she was a big help. All numbers listed below are her work numbers BTW. Hope this helps.

Jamie Matson, RN
AMS Patient Service Specialist
(952)930-6261 Office
(303)591-8599 Cell
49 years old, Suffering from ED 10+ years, Implant surgery 2/28/19 AMS 700 LGX 18cm with 4cm RTE by Dr. Terlecki at WFBMC in Winston Salem NC

alibaba
Posts: 3019
Joined: Sun Oct 12, 2014 8:04 pm

Re: AMS 700 Malfunctioning?

Postby alibaba » Thu Jul 11, 2019 12:16 am

Jamie is nice in a world full of idiots. Very helpful. I asked for my old pump beca use I wanted to cut it apart and study it. I was told it is not allowed. AMS, now Boston Scientific, soon to be who knows next like Coloplast, is well known to have glitchy pumps. I learned to deflate mine again and try over if it did not work or squeeze as hard as I could from the wrong sides to break it loose to work. Plastic does not make a real good medium for a hydraulic pump. Expands and contracts more than metals and hangs up more due to distortions. If any other manufacturer of a product produced with such a reliability record, it would be recalled. My Titan pump gets a spell once in a while, but nothing like the Asthmatic Mental Select-a-sex pump did.
LGX 21cm .Milam 01/13/16. Horror; both service and surgical outcome. hated infrapubic installation. Kramer revision 03/01/17. 22cm Titan +1.5cm extender. Those who think their opinion is the only one that matters are a danger to themselves and others.

Evinrude
Posts: 200
Joined: Sun May 05, 2019 4:02 pm
Location: SC

Re: AMS 700 Malfunctioning?

Postby Evinrude » Thu Jul 11, 2019 3:44 pm

RayChez wrote: I was all healed up within three weeks.
A bummer to realize an AMS defect is even possible...after all the pomp and circumstance leading up to and including the surgery and then 6 weeks of healing before activation, what an extreme drag it would be to find out the unit was defective and you have to go thru all that yet again ! :cry:
Age 66, widower in 2017, remarried 2019. ED symptoms just 3 years ago, Viagra worked at first but less and less so as time went on. Never tried injections. AMS 700 LGX 15cm (2cm RTE) Implant 6/19/19 Broderick @ Mayo C. JAX.

Drake1
Posts: 15
Joined: Mon Jul 08, 2019 6:34 am

Re: AMS 700 Malfunctioning?

Postby Drake1 » Thu Jul 11, 2019 5:27 pm

Lost Sheep wrote:So, you are not able to inflate the implant to a full (or even partial) erection?

Not at all! I am in a pickle...No fun for me (or my wife). :?

Drake1
Posts: 15
Joined: Mon Jul 08, 2019 6:34 am

Re: AMS 700 Malfunctioning?

Postby Drake1 » Thu Jul 11, 2019 5:29 pm

RayChez wrote:You need to get that MS pump replaced. Pretty sure that is the problem. Simple operation if they do just that, but sometimes these surgeon will do more.

But if the ball stays collapsed the valve is not resetting itself. It got stuck on the open position and will not hold the saline that is pushed into the cylinders. Pretty sure that is what happened with mine.

If you don't mind me asking...what specifically went wrong with yours and what was it doing or not doing?

Drake1
Posts: 15
Joined: Mon Jul 08, 2019 6:34 am

Re: AMS 700 Malfunctioning?

Postby Drake1 » Thu Jul 11, 2019 5:30 pm

Lunatech wrote:Contact Jamie. She's an AMS patient service specialist. If anyone can walk you through getting a pump to work again (unless it truly is broken) it's her. I've spoken with her before and she was a big help. All numbers listed below are her work numbers BTW. Hope this helps.

Jamie Matson, RN
AMS Patient Service Specialist
(952)930-6261 Office
(303)591-8599 Cell

AWESOME!!! Thank you very much for the info.


Return to “Implants”

Who is online

Users browsing this forum: andrew1959nj, Google [Bot], Josephette, Majestic-12 [Bot] and 12 guests