6 months post op discomfort

The final frontier. Deciding when, if and how.

Moderator: DaveKell

Jamie7891
Posts: 39
Joined: Sat Jun 09, 2018 6:43 pm

6 months post op discomfort

Postby Jamie7891 » Sun Jan 20, 2019 5:43 am

Hi I was implanted with ams on 14th August so now at 6months started getting a bit of pain recently within scrotom pump is not adhered moves freely but still bit of fluid surrounding the pump feels like little hard bits resembling like ball bearings but much smaller ..... I can pump to max no problem at all ,no redness or swelling but during sex to night was quite painful..... is it normal to still have discomfort at 6 months post op
31 year old :D tried pills for 5years
Trimix too painful and not spontaneous

Was implanted by dr katelaris on 13/8/18 in Sydney Adventist Hospital
With AMS 700 LGX 21cm & 3cm RTE
Revision failed pump
Dr katelaris on 23/3/2020

Larry10625

Re: 6 months post op discomfort

Postby Larry10625 » Sun Jan 20, 2019 5:57 am

Jamie7891 wrote:Hi I was implanted with ams on 14th August so now at 6months started getting a bit of pain recently within scrotom pump is not adhered moves freely but still bit of fluid surrounding the pump feels like little hard bits resembling like ball bearings but much smaller ..... I can pump to max no problem at all ,no redness or swelling but during sex to night was quite painful..... is it normal to still have discomfort at 6 months post op



I have nothing like that. :)

Larry

Jamie7891
Posts: 39
Joined: Sat Jun 09, 2018 6:43 pm

Re: 6 months post op discomfort

Postby Jamie7891 » Sun Jan 20, 2019 6:21 am

Larry10625 wrote:
Jamie7891 wrote:Hi I was implanted with ams on 14th August so now at 6months started getting a bit of pain recently within scrotom pump is not adhered moves freely but still bit of fluid surrounding the pump feels like little hard bits resembling like ball bearings but much smaller ..... I can pump to max no problem at all ,no redness or swelling but during sex to night was quite painful..... is it normal to still have discomfort at 6 months post op



I have nothing like that. :)

Larry


I just feel like the pump is within a pocket with loose sludge inside
31 year old :D tried pills for 5years
Trimix too painful and not spontaneous

Was implanted by dr katelaris on 13/8/18 in Sydney Adventist Hospital
With AMS 700 LGX 21cm & 3cm RTE
Revision failed pump
Dr katelaris on 23/3/2020

Larry10625

Re: 6 months post op discomfort

Postby Larry10625 » Sun Jan 20, 2019 9:46 am

Jamie7891 wrote:
Larry10625 wrote:
Jamie7891 wrote:Hi I was implanted with ams on 14th August so now at 6months started getting a bit of pain recently within scrotom pump is not adhered moves freely but still bit of fluid surrounding the pump feels like little hard bits resembling like ball bearings but much smaller ..... I can pump to max no problem at all ,no redness or swelling but during sex to night was quite painful..... is it normal to still have discomfort at 6 months post op



I have nothing like that. :)

Larry


I just feel like the pump is within a pocket with loose sludge inside



Jamie;
It's still early. As long as you implant continues to work the way it was designed, don't focus so much on the little things. If it starts failing or looks hideous, by all means contact you surgeon. Your body is adapting to a foreign object, maybe it has decided it doesn't like your third nut... you be the boss and ignore it. The pain, on the other hand should be addressed. :)

Larry

User avatar
Quincy
Posts: 304
Joined: Tue Mar 27, 2012 6:03 pm
Location: Boise, ID

Re: 6 months post op discomfort

Postby Quincy » Sun Jan 20, 2019 12:20 pm

Hi. I'm about 7 months post op. I don't have any pain to speak of anymore.

I do, however, have more in my sack than just the 3 boys. There is some sort of spongy mass in there, most of it between the right testicle and the pump (pump rests in the middle). If I squeeze between the pump and nut I can feel what could be described as a "sludge" I guess. It stays in that area and seems to be connected in some way to the nut and the pump. I can still move the pump everywhere, but the mass moves with it. There is no such feeling between the pump and my left nut.

I went to see my urologist about it perhaps 2 months after surgery. He felt around and said it didn't seem a problem and was probably just leftover junk from the surgery. He indicated it should go away after a while. Now that it's been 7 months and still not gone I don't know what to think. I told him it was still there when I saw him last month and he said if it isn't causing trouble not to worry about it. I don't think he ever felt it very well, however, since my scrotum gets thicker and smaller when I'm out and about. It's hard to feel unless my sack is very warm.

I don't get any pain from it, and I never get a feel like ball bearings. The mass is never hard, always soft and spongy. Given that I never felt this mass before the surgery, it does concern me a little. If I were in pain, I'd definitely look into it further. My urologist is not the person who did my surgery, and I've thought a little about going back to my surgeon even though it's a long trip. I'd suggest you tell your surgeon, and maybe get examined.

Best wishes,
Quincy
68, Boise area, Married 44 years
ED from type 2 diabetes and PCa radiation. Gleason 3+4=7
AMS LGX surgery 6/5/18 with Edward Karpman in Silicon Valley, 18cm+3RTE

RayChez
Posts: 223
Joined: Sat Mar 17, 2018 11:25 pm

Re: 6 months post op discomfort

Postby RayChez » Sun Jan 20, 2019 2:01 pm

I think it might be scare tissue that has attached itself between your testicle and the pump. I have the same thing and it does not bother me, but since I am going to have the pump replaced in a few more days, I have wondered how my testicle will react to the separation from the pump. But I am not going to worry about it. I am sure the doctor will know how to remove one from the other.
age: 75 First implant around 2001, 59 at the time. AMS 700 Ultrex
revision Dec 2016. 2ND implant 21CM, 1rte AMS 700 LGX MS pump

justanotherdrumber
Posts: 242
Joined: Sun Mar 25, 2018 11:29 pm
Location: Erie, PA

Re: 6 months post op discomfort

Postby justanotherdrumber » Sun Jan 20, 2019 5:40 pm

Jamie7891 wrote:Hi I was implanted with ams on 14th August so now at 6months started getting a bit of pain recently within scrotom pump is not adhered moves freely but still bit of fluid surrounding the pump feels like little hard bits resembling like ball bearings but much smaller ..... I can pump to max no problem at all ,no redness or swelling but during sex to night was quite painful..... is it normal to still have discomfort at 6 months post op

I never experienced pump pain, except on the 100 mile/2 hour ride home; I had the "awareness" of the new room mate while healing.

You will probably notice many changes in the pump/scrotum relationship while healing extending beyond 6 months.

Be patient, but do tell your surgeon about this.

Good luck
Erie,PA
Age 64 - g/f 34
Implanted ams700 lgx, 18cm+1cm RTE
March 2018

kosh200
Posts: 105
Joined: Mon Jun 18, 2018 12:49 pm

Re: 6 months post op discomfort

Postby kosh200 » Sun Jan 20, 2019 11:53 pm

I do believe this is the scar tissue or “capsule” that forms around the pump. I had my surgery in early September and they had to move to pump do to fluid buildup. They left the initial capsule in after they move my pump. It feels spongy and sometimes gets larger. My MD said not to worry unless it is super painful or extra hard.
45 years old. Diagnosed with Peyronies over 5 years ago. Successfully implanted on 9/6/18 with a Coloplast Titan 18 cm + 3 cm RTEs 4.5”-1st Activation, 6.25” three months of cycling. Dr. Levine. Chicago, Illinois

DougAnd
Posts: 1206
Joined: Sun Jul 08, 2018 5:10 pm
Location: Melbourne, Florida

Re: 6 months post op discomfort

Postby DougAnd » Tue Jan 22, 2019 4:09 pm

6 months for me on the 8th.
Just came from the bathroom where I checked things out. My pump is still glued to my scrotum. The only odd thing I feel is the tubes all wrapped together coming down the middle. Just had it replaced December 4th no spongy mass or lumps yet. And no pain.
LGX 18cm+3cmRTE 8 / 8/18 by Docs Saracino , Prody of FL Disfigured by Implant. Married 31 years, Functionally impotent 2+ years. 4" day of surgery now 7" inflated after VED 6.5" without. Pump moved 12/4/18 by Dr Kata


Return to “Implants”

Who is online

Users browsing this forum: mleeh2020 and 54 guests