Infection stories

The final frontier. Deciding when, if and how.
Hawkman
Posts: 556
Joined: Sat Aug 25, 2012 3:09 pm
Location: PA
Contact:

Re: Infection stories

Postby Hawkman » Sat Sep 01, 2018 11:41 am

I find this topic interesting but few of you guys mention how long after surgery it was before there were signs of infection. When do the vast majority of infections manifest themselves? How long after surgery did YOUR infection begin to manifest itself?
Prostatectomy 2004-Bimix caused Peyronies-Viagra had little effect. Active sex life with wife of 50 yrs- been dependent on a VED for 10 yrs. 22cm Titan w/Dr. Eid Aug 7th See my Implant Journal -> http://www.peyroniesforum.net/index.php/board,56.0.html

Limpbizcit
Posts: 80
Joined: Tue Nov 21, 2017 6:39 am

Re: Infection stories

Postby Limpbizcit » Sat Sep 01, 2018 5:16 pm

I noticed the clear discharge two weeks in. I kept hoping things would get better and taking antibiotics for almost two months. But two months after surgery it had to go.
Age 47. ED for over 20 years. Diagnosed with Hypogonadism. Pills and trimix do not work consistently. Implanted with 24cm AMS CX 12/12/17. Infected implant removed and replaced with AMS Spectra 2/18/18. Implanted with 26CM Titan 10/02/18. So far so good.

pal123
Posts: 7
Joined: Fri Apr 13, 2018 2:00 pm

Re: Infection stories

Postby pal123 » Sat Sep 01, 2018 8:02 pm

Limpbizcit ,

You say the antibiotics affected your kidney function. Was that only temporary while you are on them or long term.

Thanks,
Pal
Peyronie's disease
Implant surgery late June
Titan Touch 22/23.5

Jamie7891
Posts: 40
Joined: Sat Jun 09, 2018 6:43 pm

Re: Infection stories

Postby Jamie7891 » Sat Sep 01, 2018 9:37 pm

I have very minimal pain and zero discharge at day 20 post op

But to feel of the pump it’s feels as if “bio film “ has covered the device pump area can feel like it’s covered in extra layers of skin and slippery to try to palpate the pump bulb

Need to wait 2 more days to see urologist it’s killing me waiting but in my mind I’m certain it’s infection due to the buildup around the pump
31 year old :D tried pills for 5years
Trimix too painful and not spontaneous

Was implanted by dr katelaris on 13/8/18 in Sydney Adventist Hospital
With AMS 700 LGX 21cm & 3cm RTE
Revision failed pump
Dr katelaris on 23/3/2020

Limpbizcit
Posts: 80
Joined: Tue Nov 21, 2017 6:39 am

Re: Infection stories

Postby Limpbizcit » Sat Sep 01, 2018 11:09 pm

pal123 wrote:Limpbizcit ,

You say the antibiotics affected your kidney function. Was that only temporary while you are on them or long term.

Thanks,
Pal

It was temporary. It started to return to normal by the fourth day in the hospital.
Age 47. ED for over 20 years. Diagnosed with Hypogonadism. Pills and trimix do not work consistently. Implanted with 24cm AMS CX 12/12/17. Infected implant removed and replaced with AMS Spectra 2/18/18. Implanted with 26CM Titan 10/02/18. So far so good.

Limpbizcit
Posts: 80
Joined: Tue Nov 21, 2017 6:39 am

Re: Infection stories

Postby Limpbizcit » Sat Sep 01, 2018 11:11 pm

Jamie7891 wrote:I have very minimal pain and zero discharge at day 20 post op

But to feel of the pump it’s feels as if “bio film “ has covered the device pump area can feel like it’s covered in extra layers of skin and slippery to try to palpate the pump bulb

Need to wait 2 more days to see urologist it’s killing me waiting but in my mind I’m certain it’s infection due to the buildup around the pump

Hoping for the best.
Age 47. ED for over 20 years. Diagnosed with Hypogonadism. Pills and trimix do not work consistently. Implanted with 24cm AMS CX 12/12/17. Infected implant removed and replaced with AMS Spectra 2/18/18. Implanted with 26CM Titan 10/02/18. So far so good.

BustedBob
Posts: 43
Joined: Sun Oct 08, 2017 9:31 am

Re: Infection stories

Postby BustedBob » Tue Sep 04, 2018 4:59 pm

I had an infection around ten days after the op, started with hot sweats and pain but ended up with delirious hospitalisation. Lucky for me it was urinary and not the implant, which is still in there.
45
ED 20 plus years-venous leakage, Peyronies for the last 3 years.
Implanted October 2017 at UCLH London, England. Titan Touch.

SARocker
Posts: 22
Joined: Sun Aug 05, 2018 8:21 am

Re: Infection stories

Postby SARocker » Fri Sep 07, 2018 10:02 pm

I’m currently at week 6 and I started noticing a weird pimple on the top of my urethra at week 4. The doctor did not worried about it and prescribed some cream to apply. At week 5 things got ugly and this time, he prescribed antibiotics. I haven’t had a fever and the implant feels just fine (even able to inflate and deflate without any issue). It is looking like a rash and I have red spots on my glands, but after reading a lot on the forum, this might not be an infection. I’ll confirm once I received my tests back (gram-stain, painful AF). It hurted really bad before the painkillers and antibiotics. Other thing is that my doctor hasn’t mentioned once about a reoperation. He just prescribed a 20 days treatment with antibiotics and painkillers.
33 yo, implanted on July 24, 2018. AMS 700 LGX, IZ. 21 cms x 12 mm with 0.5 RTE

brand6666
Posts: 6
Joined: Mon Aug 20, 2018 5:24 pm

Re: Infection stories

Postby brand6666 » Thu Sep 13, 2018 12:54 pm

I had a implant put in 2 years ago the reservoir must of had a leak cause it was empty I had it removed and a 2nd one implanted but I caught a infection had that removed its been 6 moths and dim going in October to have a 3rd one put in I hope this one works fine The infection I had leak all over my underwear and on to my sheets I was in no pain at all with both of them
L/A Maine


Return to “Implants”

Who is online

Users browsing this forum: Baidu [Spider], Cameron, Gt1956 and 29 guests