Search found 28 matches

by readyforchange
Thu Jan 30, 2020 9:51 pm
Forum: Implants
Topic: Update and Question/Issue
Replies: 13
Views: 767

Re: Update and Question/Issue

So I believe the tubing made an "ivy" sort of latching onto the left valve block-end, which makes it difficult to reset by pressing the block-ends. In any event, I am heading to see Dr. Kramer on Monday morning thankfully. I haven't been able to pop the valve into inflate mode still. The s...
by readyforchange
Tue Jan 28, 2020 8:14 pm
Forum: Implants
Topic: Update and Question/Issue
Replies: 13
Views: 767

Re: Update and Question/Issue

Makes sense. I’m going to give it some tried tonight. I’ll check in and let you guys know how it goes.
by readyforchange
Tue Jan 28, 2020 7:42 pm
Forum: Implants
Topic: Update and Question/Issue
Replies: 13
Views: 767

Re: Update and Question/Issue

I’ll give that a try! It’s very odd. One question I have is whether you guys squeeze and squeeze until you get the pop? Or do you squeeze once and then hit the deflate button? I think that might be an issue...i think I tend to look for the pop which comes after two or three firm presses but now I’ve...
by readyforchange
Tue Jan 28, 2020 6:19 pm
Forum: Implants
Topic: Update and Question/Issue
Replies: 13
Views: 767

Re: Update and Question/Issue

I did and they provided me so techniques. It’s really odd! I’m sort of lost as to what to do. I think the valve is stuck on deflate and won’t click over.

I have the AMS LGX 700.

I might try the hitting deflate and pumping at the same time technique to reset.
by readyforchange
Tue Jan 28, 2020 3:33 pm
Forum: Implants
Topic: Update and Question/Issue
Replies: 13
Views: 767

Re: Update and Question/Issue

Thanks! Going to Kramer next week. The pump bulb isn't hard and it gives but nothing is flowing. I may attempt a reset and trying to get my hands on both ends of the block tonight!
by readyforchange
Sun Jan 26, 2020 8:40 pm
Forum: Implants
Topic: Update and Question/Issue
Replies: 13
Views: 767

Update and Question/Issue

Hi Everyone: I wish I was on here more! Work has been a headache but a good kind. Let me say this: getting an implant has been miraculous and I have no regrets. The people on this forum are incredible. To that point, I thank all of you. So the last two days, I’ve had some weird issues with the pump....
by readyforchange
Mon Dec 09, 2019 8:35 pm
Forum: Implants
Topic: Trouble with scab, chafing, and swelling still
Replies: 4
Views: 345

Re: Trouble with scab, chafing, and swelling still

Hey! I did talk to Dr. Kramer - the inflammation goes down (it is down now and just scabbed). Anyhow, Dr. Kramer did say that he thinks it’s the residual and inflammation from the recovery. Believes it’ll take time to heal up. I think it has to do with the tips and then staying straight while I’m st...
by readyforchange
Mon Dec 09, 2019 12:20 am
Forum: Implants
Topic: Trouble with scab, chafing, and swelling still
Replies: 4
Views: 345

Trouble with scab, chafing, and swelling still

Hey all: I’m about 3 months out of surgery! Everything is good...but only issue is this real issue with swelling below the glans. I will have a ton of swelling post/during sex. I do still have peyronies curve (not as bad) where the curve would go horizontally to the left. It has improved post surger...
by readyforchange
Fri Nov 08, 2019 1:20 pm
Forum: Implants
Topic: Re: Tip Irritation/Swelling Under glans
Replies: 2
Views: 305

Re: Tip Irritation/Swelling Under glans

Hey all!

So here is the photo!
IMG_2136.jpeg
IMG_2136.jpeg (463.08 KiB) Viewed 199 times
by readyforchange
Thu Nov 07, 2019 5:53 pm
Forum: Implants
Topic: Re: Tip Irritation/Swelling Under glans
Replies: 2
Views: 305

Re: Tip Irritation/Swelling Under glans

Hi All: So I’m doing well! Able to cycle and been doing much better. Took a while (like 5.5 weeks to really get moving). Anyways, when I cycle, no issues. I had peyronies and while cycling provides no issues, when I have intercourse, the tips area and under glans swell bad and look blistery. It gets...

Go to advanced search